티스토리 뷰

라이브러리 설치

# PHP >= 5.4
$ composer require respect/validation

# PHP >= 5.3.23
$ composer require respect/validation:0.9.8

라이브러리 사용 예

use Respect\Validation\Validator as v;

v::in(array('Korea', 'Japan'))->validate('Korea'); // true
v::in(array('Korea', 'Japan'))->validate('USA'); // false

v::startsWith('South')->validate('South Korea'); // true
v::startsWith('South')->validate('North Korea'); // false

v::charset('UTF-8')->validate('한국어'); // true
v::charset('EUC-KR')->validate('한국어'); // false

v::email()->validate('jsonobject@gmail.com'); // true

v::json()->validate('{"foo":"bar"}'); // true

참고 글

댓글
댓글쓰기 폼